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OVERVIEW 

This tutorial is intended to present to you the 3D Machining Wizard, which makes 3D 

part programming easier than the regular Work Step Data window. The 3D Machining 

Wizard collects information about the most important machining parameters from the 

user, in a brief window, avoiding confusing settings. Some parameters are pre-defined to 

the most appropriate values for the current machining method; however, the user always 

has the option to alter them as to his needs. 

 

The solid model can be imported into EZ-MILL Pro in several file formats, like sldprt, 

igs, step, sat, x_t or x_b. Beginning from version 19, SolidWorks users can transfer the 

3D model directly from the SolidWorks working window to EZ-CAM in one click. The 

3D Machining Wizard automatically detects and assigns all the surfaces to the recently 

created Work Step; however, the user can choose to deselect any of them. 

 

Throughout the tutorial you will find important notes  , tips   or references to the 

online help where additional information on the commands and functions is provided. 

 

 

CAVITY MACHINING 

In this tutorial we will machine a detergent bottle mold. It is a cavity of a bottle divided 

from the centerline. It has a boss corresponding to the handle portion, which creates an 

island in the middle of the cavity. The mold cavity has both steep and flat sections which 

we need to consider at the finishing stage. Surface transitions have fillets in several 

dimensions. 

 

The first operation will be roughing with a large tool to get rid of the bulk material inside 

the cavity. Secondly we will apply a re-roughing workstep to machine the uncut material 

with a relatively small tool. The finishing operation will be carried out by a 3D 

Equidistant machining method providing even surface roughness throughout the mold. 

Finally we will introduce a re-finishing technique and cut the remaining material left by 

the relatively lager tool of the previous finishing operation. 
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BASIC PROGRAMMING STEPS 

Before we continue with the tutorial let us explain the basic steps needed to create the part 

program. 

 

 

STEP 1.  Load (Import) the 3D Solid Model of the Part to be machined 

For our sample part we will use a 3D model created in Rhino and saved 

in ACIS format “sat”. Other common CAD translation formats can also 

be used to import external data to EZ-Mill Pro, such as igs, 3dm, step, 

x_t, x_b, etc. SolidWorks users can directly transfer the solid model to 

the EZ-CAM window using the “Update Solidworks Model” command. 

 

 

STEP 2.  Define World/UCS origin on the 3D Solid Model 

We will change the World/UCS origin point to a reference location on 

the real part stock. 

 

 

STEP 3.  Create Work Steps and set all Machining Parameters 

We will create machining work steps, specify tool and operation 

parameters, create path Curves (if required), and verify the toolpaths. 

Also we will create rough and re-rough surface milling operations, 

leaving stock on all surfaces then finish and re-finish surface milling 

operations; removing the remaining material, leaving minimal cusps. 

 

 

STEP 4.  Check Material Removal and Surface Finish 
We will check to make sure all material is removed and the surface 

finish smoothness is acceptable. 

 

 

   

The EZ-MILL Pro 3D Machining Wizard Tutorial is set up in Inch 

with all Inputs and Dimensions in Inch ! 
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THE PART 

Below is the image of the sample part we will machine in this tutorial. It is a detergent 

bottle mold with an approximate size of 13.5”x11.5”. The cavity of the mold has steep 

walls near the top surface, and a boss with steep walls corresponding to the handle of the 

bottle. There are fillets with radii changing between .079” and .2” in surface transition 

sections.  

 

 

 

 
 

 

Picture 1-1 
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SETTING THE PREFERENCES 

Let’s first set some important parameters such as units and other viewing preferences to 

ensure the compatibility of your system with the tutorial.  

 

1. Select the ”New” command from the “File” menu to restart EZ-Mill Pro and to clear 

the memory before continuing with the tutorial. Make sure the “EZ-Mill Pro” level is 

active and press OK to start over. 

 

 
 

 

  
 

The “New” dialog is also used to switch between the EZ-Mill and 

EZ-Turn modules. Before the dialog opens the system checks the 

software protection key for activated modules. Modules or levels 

that are not activated will be marked by appended “DEMO” text. 

When working in “Demo” (evaluation) mode, it is not possible to 

print or save data. The corresponding “Save”, “Save as” and 

“Print” commands are disabled. 

 

When closing the EZCAM application, the system automatically 

stores the last used level as default for the next session. 

 

2. Select the ”Setup” command from the “View” menu 

 

3. Select the “Inch” option button as the input dimension system. 

 

4. Click the “Background” list box and select “White”. 

 

5. Click the “Show Toolpath” list box and select "Blank Verify”. This will cause 

verified tool paths to be blanked when the screen is redrawn. 
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6. Click the “Show Direction” list box and select "None". This will hide the small 

arrows indicating the surface normals and curve directions. It can later be activated at 

any time. 

 

7. Check "Save as Default". The system will store all dialog settings as defaults for 

future sessions. 

 

8. After the preferences have been correctly set, click OK. 

 

 
 

Picture 1-2 

 

 

The initial setup for the EZ-MILL Pro 3D Machining Wizard Tutorial is now complete. 

Continue with the next section to create the geometry necessary for this part. 
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LOADING THE SOLID PART 

We will begin the exercise by loading the surface geometry that represents our part. There 

are several methods to accomplish this process. The first method is to import a 

solid/surface type of model into EZ-CAM in one of the common CAD file formats, such 

as iges, sat, step, sldprt, sldasm, x_t, x_b, dwg, vda or 3dm. Secondly, you can open the 

model in our companion CAD product, Rhino, then copy/paste to EZ-Mill using the 

special command “Paste from Rhino” found under the “Edit” menu. The last method is 

for SolidWorks users; they can load the model into SolidWorks and transfer the file to 

EZ-CAM by using the new “Update Solidworks Model” command. In this tutorial we 

choose the first method and load a SAT file representing the 3D model. 

 

   

You may refer to “EZ-Mill 3D Machining Solids Tutorial” to get 

information about “Copy and Pasting the Model from Rhino” 

 

The “SAT” file containing the 3D model has already been copied into the 

“EZCAMW\MILLPARTS” folder by the EZ-CAM setup. Follow the steps below to load 

the data. 

 

 
 

Picture 1-3 

 

 

1. Select the “Open” command from the “File” menu to open the file dialog. In Picture 

1-3 you can see the dialog displayed on a Windows Vista workstation system. This 
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dialog may vary according to the version of the Windows operating system running 

on your machine. 

 

2. Select the folder “EZCAMW \ MILLPARTS” on the drive where you installed the 

software 

 

3. In the “Files of Type” list select “ACIS Solid Models (*.sat)”. 

 

4. Select the file “Detergent Bottle Mold-inch.sat” and click the “Open” button. The 

imported surface geometry should then appear as shown in Picture 1-4. 

 

 

 

 
 

Picture 1-4 
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DEFINING WORLD/UCS ORIGIN OF THE PART 

We will define the part origin point as the zero position that will be assigned to the stock 

before machining on the CNC machine. In this tutorial the front left corner of the part 

block will be selected as the origin point--using the default coordinate system “World”. 

The top plane of the part will be designated as Z=0 position. 

 

 

1. To define the new “World” origin point, select the “World/UCS, Three Points” 

command from the “View” menu or click the corresponding button. 

 
World/UCS, Three Points 

 

2. Select the “Snap All” command from the “Edit > Point Picking” menu or click the 

corresponding button.  

 
Snap All 

 

3. Click the corner points 1, 2 and 3 on the part; See Picture 1-5. These points 

designate new origin point, X-axis direction and Y-axis direction respectively. 

 

 
 

Picture 1-5 
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4. The part will be oriented as to the new position of “World” coordinate system that is 

appropriate for machining as shown in Picture 1-6. 

 

 

 
 

Picture 1-6 
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CREATING THE PART PROGRAM 

Now that we have completed setting the origin point of the part we are ready to begin 

defining the work steps to machine it. Each work step uses a specific method (Roughing, 

Finishing, etc.) and a Toolpath Type (Pocketing, Parallel, etc.) along with its associated 

tool settings and parameters to create a toolpath that machines the assigned curves and 

surfaces. Our part program will consist of the following work steps. 

 

 

Work Step ID Purpose 

Roughing 

Rough the cavity leaving a stock allowance of .005” with a .625” 
flat tool. We will use a Pocketing toolpath pattern generated 
within the boundaries of each surface slice computed using a  
Z-step value of .04”. 

Re-Roughing 

 

Machine the uncut material sections where the previous tool of 
the Roughing operation could not fit. The system will 
automatically detect each uncut boundary and create an auxiliary 
curve. A pocketing type of toolpath will be used with a relatively 
smaller flat tool with a diameter of .1875”. 

Finishing 

 

Finish the cavity surfaces, limited by the curves defining the outer 
and inner boundaries. The 3D Equidistant type of toolpath will 
generate evenly distributed toolpath passes all around the 
finished surfaces. A ball nose tool with a diameter of .375” will be 
used. 

Re-Finishing 

Re-Finish the rest material remaining from the Finishing 
operation, using a relatively smaller ball nose tool with a diameter 
of .125”. The system will automatically detect the sections that 
have smaller indentation and concavity than the Finishing tool 
can cut and generate a 3D toolpath around them. 
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CREATING WORK STEP “1_ROUGHING” 

The first work step will machine the bulk material inside the cavity in order to prepare it 

for the finishing operation. We will use the “3D Machining Wizard” for defining the 

machining parameters. The wizard automatically selects all the visible surfaces as “cut 

surfaces” and sets the “surface” parameter in the Z Data section to the highest Z point of 

the surfaces. Besides it sets several parameters to the most appropriate values for the 

active operation. We will not specify any boundary curves for the roughing operation and 

let the system detect the outer boundary (silhouette) of the cut surfaces. 

 

1. Select the “3D Machining Wizard” command in the “Machining” menu or click the 

corresponding button. 

 
3D Machining Wizard 

 

2. Input “1_ROUGHING” as the new Work Step ID. Confirm with OK. 

 
 

3. Select “ROUGHING” from the Method list box. 

 

 
 

 

4. Select “Pocketing” from the Toolpath Type list box. Until a toolpath type is selected 

all other input boxes appear as disabled. 
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5. On the “3D Machining Wizard” window, change the settings according to the table 

below and ensure that all parameters are set as shown in Picture 1-7. 

 

Dialog Field Value Comment 

Type Flat Flat type endmill 

Number 1 Tool number in tool magazine 

Diameter (Bot.) 0.625 Defines the diameter of the tool  

Spindle RPM 750 Sets spindle RPM to 750 

Feed (X-Y) 50 Cutting feed rate in XY plane (inches/minute) 

Feed (Z) 5 Cutting feed rate for Z depth moves 

Surface 0 
Set our Z surface to the top of the block. This 
value is automatically detected by the system 
as the top point of the solid body. 

Rapid 0.5 
Rapid positioning plane over “Z Surface” plane 
during transversal rapid moves 

Clear 0.05 
Plunge plane over “Z Surface” plane (Rapid to 
Feedrate) 

Step-Z 0.04 Incremental depth per Z-level pass 

Fin Allow 0.005 
Finishing allowance value. Material that 
remains along the surfaces to be removed later 
with the finishing operation 

Step Over 50% 

The distance between the tool passes on the 
machining plane. The value is given as the 
percentage of the tool diameter. (you may opt 
to use an absolute value instead) 
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Picture 1-7 
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6. Click the “Verify” button and the system starts calculating the toolpath. See Picture 

1-8. 

 
Verify 

 
 

Picture 1-8 

 

 

 

The Work Step #1 is now complete. Hit the “Redraw” button  to refresh the 

screen and remove the verified tool path display. 
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CREATING WORK STEP “2_RE-ROUGHING” 

The second machining work step will remove material only in the sections where the 

roughing tool could not fit. We will use a tool with a relatively smaller diameter. 

EZ-CAM system will detect the uncut boundaries at every roughing slice of the reference 

Work Step, and create an auxiliary curve that will be machined according to the selected 

re-roughing toolpath type. 

 

1. Select the “3D Machining Wizard” command in the “Machining” menu or click the 

corresponding button. 

 
3D Machining Wizard 

 

2. Input “2_RE-ROUGHING” as the new Work Step ID. Confirm with OK. 

 
 

3. Select “RE-ROUGHING” from the Method list box. 

 

4. Select “Pocketing” from the Toolpath Type list box. 

 

 
 

 

5. Select “1_ROUGHING” from the Ref.Work Step list box. 
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6. On the “3D Machining Wizard” window, change the settings according to the table 

below and ensure that all parameters are set as shown in Picture 1-9. 

 

Dialog Field Value Comment 

Type Flat Flat type endmill 

Number 2 Tool number in tool magazine 

Diameter (Bot.) 0.1875 Defines the diameter of the tool  

Spindle RPM 2000 Sets spindle RPM to 2000 

Feed (X-Y) 15 Cutting feed rate in XY plane (inches/minute) 

Feed (Z) 5 Cutting feed rate for Z depth moves 

Surface 0 
Set our Z surface to the top of the block. This 
value is automatically detected by the system 
as the top point of the solid body. 

Rapid 0.5 
Rapid positioning plane over “Z Surface” plane 
during transversal rapid moves 

Clear 0.05 
Plunge plane over “Z Surface” plane (Rapid to 
Feedrate) 

Step-Z 0.04 

Incremental depth per Z-level pass is 
automatically set to the same value as the 
reference work step, however can be reduced 
to a lower value in order to decrease the tool 
load 

Step Over 50% 

The distance between the tool passes on the 
machining plane. The value is given as the 
percentage of the tool diameter. (you may opt 
to use a decimal value instead) 
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Picture 1-9 
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7. Click the “Verify” button and the system starts calculating the toolpath. See Picture 

1-10. 

 
Verify 

 
 

Picture 1-10 

 

 

 

8. An auxiliary curve in yellow representing the machining area around the uncut 

sections appears after generating the toolpath. In order to hide it, select the “Blank” 

command from the “Edit” menu or click the corresponding button.  

 
Blank 

 



CHAPTER 1 

1-20 EZ-CAM 

9. Select the curve “1_ROUGHING-rest” in the object list box. The yellow uncut 

boundary curve and the toolpath disappear. 

 

 
 

 

10. Click the “Escape” button in the toolbar or hit “Esc” button on the keyboard to abort 

Blank command and to prevent accidental selection of an object on the screen.  

 
Escape 
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DEFINING THE BOUNDARY CURVES FOR FINISHING OPERATION 

We need to create curves to define machining borders for our finishing operation by using 

the solid model representation of the 3D part. We have few choices  for curve creation 

from the 3D model such as “Face Boundary”, “X-Y Intersection” or “Silhouette 

Boundary” commands. Here we use Face Boundary command to create the outer 

boundary of the mold cavity and inner boundary from the flat surface around the handle 

section. 

 

 

1. To create the outer finishing boundary curve choose the “Face Boundary” command 

from the “Curves“ menu, type “outer” as the Curve ID and click OK. 

 
Face Boundary 

 
  

 

2. Select the “Verify Mode” command in the “Edit” menu or click the corresponding 

button. This mode displays the selected object in different color and waits for our 

confirmation allowing us to abort the process or continue selecting multiple objects. 

 
Verify Mode 

 

 

3. Now we should select the surface on the part from which the face boundary curve 

will be created. Click anywhere on the outermost top surface. After clicking, the 

color of the surface changes to inform you that it’s selected. See Picture 1-11. 
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Picture 1-11 

 

 

4. Click the “Enter” button in the toolbar or hit “ENTER” button on the keyboard to 

confirm. See Picture 1-12.  

 
Enter 

 

 

 
 

 

Picture 1-12 
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5. We only need the curve created at the intersection of the top plane and the cavity. So 

it is better to delete the outermost one to prevent confusion. Select the “Delete” 

command from the “Edit” menu or click the corresponding button. Then select the 

“Curve…” command from the “Edit > Discrimination” menu or click the 

corresponding button. 

  
Delete Discrim. Curves 

 

 

6. Click the blue curve on the outer edge of the part and hit ENTER. See Picture 1-13. 

 

 
 

Picture 1-13 

 

 

 

7. For creating the inner finishing boundary curve choose the “Face Boundary” 

command from the “Curves“ menu, type “inner” as the Curve ID and click OK. 

 
Face Boundary 

 
  

 



CHAPTER 1 

1-24 EZ-CAM 

8. Click the planar surface on top of the boss in the cavity corresponding to the handle 

of the bottle. After clicking, the color of the surface changes to inform you that it’s 

selected. See Picture 1-14. 

 

 
 

Picture 1-14 

 

 

9. Click the “Enter” button in the toolbar or hit “ENTER” button on the keyboard to 

confirm. You can see the result in Picture 1-15.  

 

 
 

Picture 1-15 
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CREATING WORK STEP “3_FINISHING” 

In our third work step we will finish the cavity surface using our most efficient finishing 

technique “3D Equidistant”. This technique ensures an equal 3D distance between 

adjacent toolpath passes resulting in an even surface roughness all over the part 

eliminating the need for another finishing operation if the step over value is adequate. 

 

1. Select the “3D Machining Wizard” command in the “Machining” menu or click the 

corresponding button. 

 
3D Machining Wizard 

 

2. Input “3_FINISHING” as the new Work Step ID. Confirm with OK. 

 
 

3. Select “FINISHING” from the Method list box. 

 

 
 

 

4. Select “3D Equidistant” from the Toolpath Type list box. 

 

5. Select “outer-1” from the Path list box to define outermost machining boundary. 

 

6. Select “inner” from the 2nd Path list box to define the island region that should not 

be machined by the finishing operation. 
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7. On the “3D Machining Wizard” window, change the settings according to the table 

below and ensure that all parameters are set as shown in Picture 1-16. 

 

Dialog Field Value Comment 

Type Ball Ball type endmill 

Number 3 New tool number for finishing operation 

Diameter (Bot.) 0.375 Defines the full diameter of the tool  

Spindle RPM 1500 Sets spindle RPM to 1500 

Feed (X-Y) 30 Cutting feed rate in XY plane (inches/minute) 

Feed (Z) 5 Cutting feed rate for Z depth moves 

Step S-Link 

This parameter controls the step over moves 
between toolpath passes. S-Link eliminates 
any possible corner on the step over move 
eliminating knocking effect and ensuring 
smoother operation of the machine 

Fin Allow 0 
Finishing allowance value is set to 0 to reach 
the final surface after performing this operation 

Step Over 10% 

For 3D Equidistant type of toolpath Step Over 
is the 3D distance between the tool passes. 
The value is given as the percentage of the 
tool diameter. Since we want to leave minimal 
cusps on the surface “Step Over” distance is 
set as 10% of the tool diameter. However, 
lower values can be preferred to obtain 
smoother surface finish. 

Outside-In 
Milling 

ON 

Click this checkbox to generate the toolpath 
starting from the outermost loop and collapsing 
to the center. This ensures toolpath loops 
arranged from top to bottom 
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Picture 1-16 
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7. Click the “Verify” button and the system starts calculating the toolpath. See Picture 

1-17. 

 
Verify 

 
 

Picture 1-17 

 

 

 

The Work Step #3 is now complete. Hit the “Redraw” button  to refresh the 

screen and remove the verified tool path display. 
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CREATING WORK STEP “4_RE-FINISHING” 

In our last machining work step we will remove the material left in the areas with smaller 

indentation and concavity than the Finishing tool could complete. We will select the last 

finishing operation as the Reference Work Step and pick a relatively smaller tool. Then 

the system will automatically detect the uncut boundaries and generate a 3D Equidistant 

finishing toolpath. 

 

1. Select the “3D Machining Wizard” command in the “Machining” menu or click the 

corresponding button. 

 
3D Machining Wizard 

 

2. Input “4_RE-FINISHING” as the new Work Step ID. Confirm with OK. 

 
 

3. Select “RE-FINISHING” from the Method list box. 

 

 
 

 

4. Select “3_FINISHING” from the Ref.Work Step list box. 
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5. On the “3D Machining Wizard” window, change the settings according to the 

Picture 1-18 below and ensure that all parameters are the same. 

 

 

 
 

Picture 1-18 
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6. Click the “Verify” button and the system starts calculating the toolpath. See Picture 

1-19. 

 
Verify 

 
 

Picture 1-19 

 

 

 

The Work Step #4 is now complete. Hit the “Redraw” button  to refresh the 

screen and remove the verified tool path display. 
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3D SOLID MODEL PREVIEW 

One of the most powerful EZ-CAM features is the 3D solid preview function. This 

function shows an animated tool cutting a solid model of the programmed part. After 

previewing our program we are left with an accurate solid model representation, which 

allows us to closely examine the surface finish and resulting part details. If no stock was 

defined prior to calling the “3D Preview” or “RapidCut” commands, the system 

automatically calculates the stock size by adding a small margin to the sides and to the 

bottom of the visible solid model on the screen. 

 

1. Select the “Stock & Optimization Setup” command from the “Machining” menu and 

click “Auto Setup”, values should appear as shown in Picture 1-20. You may also 

enter your own values if the stock is different from the solid model boundaries. 

Clicking and activating “Clash Detection” makes the system detect and warn you 

about the collisions between the tool and the stock. Also click “Save Simulation” to 

enable browsing through simulation results of each work step (see Paragraph – 4). 

Close the dialog with OK. 

 

 

 

Picture 1-20 
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It is not necessary to open “Stock & Optimization Setup” window 

and run Auto Setup if you are executing the solid simulation for the 

“first time”, system calculates the stock boundaries automatically. 

But if somehow the stock size or position is improper at any time, 

you may need to run Auto Setup or input your own values that 

describe the real stock that will be mounted on the CNC machine. 

 

If you need information about using custom stock for the solid 

simulation please refer to the Indexing section of the “EZ-MILL 4th 

Axis Tutorial”. 

 

 

2. Start the simulation using “3D Preview” command from the “Machining” menu or 

the corresponding button. The simulation speed can be controlled any time by 

pressing one of the numeric keyboard buttons (not the ones on the num-pad side), 

ranging from 1 (slowest) to 9 (fastest). Pressing 0 will activate Step Mode. If you 

need to see the simulation result immediately, you can use “RapidCut” command by 

executing it from the “Machining” menu or the corresponding button. The simulation 

result is shown in Picture 1-21. 

  
3D Preview Rapid Cut 

 

 

 

Picture 1-21 
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3. During 3D simulation you can change the on-screen view by using the dynamic view 

commands (Rotate, Pan, Zoom) with their corresponding buttons. Alternatively you 

can activate rotate by holding down right button and pan by holding down middle 

button of the mouse while dragging it on the screen. As usual mouse wheel executes 

zoom command during the simulation as well. 

   
Dynamic Rotate Dynamic Zoom Dynamic Pan 

 

 

4. After completing the 3D simulation it is possible to browse through the simulation 

results of each work step. Simply click the desired works step from the list box at the 

right size of the screen and EZ-CAM instantly shows the situation at the end of the 

selected work step. Click “2_RE-ROUGHING” in the Work Step list box, you will 

see the simulation result at the end of second operation “re-roughing”. See Picture 1-

22. 

 

 

 
 

Picture 1-22 
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5. Click “3_FINISHING” in the Work Step list box, you will see the simulation result 

of the third operation “finishing”. See Picture 1-23. 

 

 

 
 

Picture 1-23 

 

 

   

Alternatively, after first clicking on one of the work steps in the list 

box you can use “up”  and “down”  arrow keys on the 

keyboard in order to browse through the simulation stages. 

 

If you have returned to the CAD view and now want to see the 

simulation model at a specific work step (or to start simulation from 

the corresponding stage), use Recall Part command from 

“Machining” menu to view the model at the end of the active work 

step (that is selected in the list box) and then start simulation. 

 

 

 

Congratulations! 

 

You've completed the EZ-MILL Pro 3D Machining Wizard Tutorial ! 


